standardize Makefile, change section from base to utils
[openwrt/staging/mkresin.git] / openwrt / package / udev / Makefile
index 39d79b4c01e6f9b54505ad7347a84e41d1035664..e942442032f4405ccf545074b4a422679547c1d2 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -5,29 +11,35 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=udev
 PKG_VERSION:=077
 PKG_RELEASE:=1
-PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
        http://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
        ftp://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
        http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
        ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
        http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
 PKG_CAT:=bzcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-include $(TOPDIR)/package/rules.mk
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-$(eval $(call PKG_template,UDEV,udev,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+include $(INCLUDE_DIR)/package.mk
 
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
+define Package/udev
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Dynamic device management subsystem
+  DESCRIPTION:=\
+       udev provides a dynamic device directory containing only the files for \\\
+       actually present devices. It creates or removes device node files in \\\
+       the /dev directory, or it renames network interfaces.
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
+endef
 
-$(PKG_BUILD_DIR)/.built:
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS="$(TARGET_CROSS)" \
                STRIP="/bin/true" \
@@ -35,26 +47,23 @@ $(PKG_BUILD_DIR)/.built:
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install -c" \
                all install
-       touch $@
-
-$(IPKG_UDEV):
-       install -d -m0775 $(IDIR_UDEV)/etc/udev
-       $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(IDIR_UDEV)/etc/udev/
-       install -d -m0775 $(IDIR_UDEV)/lib/udev
-       install -d -m0775 $(IDIR_UDEV)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(IDIR_UDEV)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(IDIR_UDEV)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(IDIR_UDEV)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(IDIR_UDEV)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(IDIR_UDEV)/sbin/
-       install -d -m0775 $(IDIR_UDEV)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(IDIR_UDEV)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(IDIR_UDEV)/usr/bin/
-       install -d -m0775 $(IDIR_UDEV)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(IDIR_UDEV)/usr/sbin/
-       $(RSTRIP) $(IDIR_UDEV)
-       $(IPKG_BUILD) $(IDIR_UDEV) $(PACKAGE_DIR)
-
-mostlyclean:
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       rm -f $(PKG_BUILD_DIR)/.built
+endef
+
+define Package/udev/install
+       install -d -m0775 $(1)/etc/udev
+       $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
+       install -d -m0775 $(1)/lib/udev
+       install -d -m0775 $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
+       install -d -m0775 $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
+       install -d -m0775 $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,udev))