treewide: clean up download hashes
[openwrt/staging/mkresin.git] / package / boot / uboot-zynq / Makefile
index 2053e8dc0791f65f98f94a6c6a71691f813071c6..61bb99dda21438923ba007d54a6666e27a5ed507 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2016.03
@@ -14,7 +15,7 @@ PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
 
-PKG_MD5SUM:=973c1d896be751321cc3aafa564f64b2
+PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -41,9 +42,14 @@ define uboot/zed
        TITLE:=U-Boot $(PKG_VERSION) for Avnet Digilent ZedBoard Dev Board
 endef
 
+define uboot/zybo
+       TITLE:=U-Boot $(PKG_VERSION) for Digilent Zybo Dev Board
+endef
+
 UBOOTS := \
        zc702 \
        zed \
+       zybo \
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
@@ -76,7 +82,7 @@ endef
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS)
+               CROSS_COMPILE=$(TARGET_CROSS) DTC=$(LINUX_DIR)/scripts/dtc/dtc
 endef
 
 define Package/uboot/install/default