update busybox to v1.3.1, i was too lazy to update patch 320, feel free to do so
[openwrt/staging/mkresin.git] / package / busybox / patches / 913-libbb_hash.patch
index a7c2291caa28f03e1396a37bdbd2f37293d4c128..dc29bb05c0d3aaacd66625c52940a56d3b0c795f 100644 (file)
@@ -5,10 +5,10 @@
 #
 # expose (again) an hash_fd function (used in 911-ipkg.patch)
 #
-diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/coreutils/md5_sha1_sum.c
---- busybox-1.2.0-orig/coreutils/md5_sha1_sum.c        2006-07-01 00:42:07.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/coreutils/md5_sha1_sum.c  2006-07-22 17:08:02.000000000 +0200
-@@ -16,79 +16,10 @@
+diff -ruN busybox-1.3.1-orig/coreutils/md5_sha1_sum.c busybox-1.3.1-913/coreutils/md5_sha1_sum.c
+--- busybox-1.3.1-orig/coreutils/md5_sha1_sum.c        2006-12-27 05:54:50.000000000 +0100
++++ busybox-1.3.1-913/coreutils/md5_sha1_sum.c 2006-12-28 00:59:35.000000000 +0100
+@@ -8,78 +8,10 @@
  
  #include "busybox.h"
  
@@ -20,17 +20,14 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
  
 -/* This might be useful elsewhere */
 -static unsigned char *hash_bin_to_hex(unsigned char *hash_value,
--                                                                        unsigned char hash_length)
+-                              unsigned hash_length)
 -{
--      int x, len, max;
--      unsigned char *hex_value;
--
--      max = (hash_length * 2) + 2;
--      hex_value = xmalloc(max);
--      for (x = len = 0; x < hash_length; x++) {
--              len += snprintf((char*)(hex_value + len), max - len, "%02x", hash_value[x]);
+-      int len = 0;
+-      char *hex_value = xmalloc((hash_length * 2) + 2);
+-      while (hash_length--) {
+-              len += sprintf(hex_value + len, "%02x", *hash_value++);
 -      }
--      return (hex_value);
+-      return hex_value;
 -}
 -
 -static uint8_t *hash_file(const char *filename, hash_algo_t hash_algo)
@@ -45,11 +42,13 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -      void (*update)(const void*, size_t, void*);
 -      void (*final)(void*, void*);
 -
--      if (strcmp(filename, "-") == 0) {
--              src_fd = STDIN_FILENO;
--      } else if(0 > (src_fd = open(filename, O_RDONLY))) {
--              bb_perror_msg("%s", filename);
--              return NULL;
+-      src_fd = STDIN_FILENO;
+-      if (filename[0] != '-' || filename[1]) { /* not "-" */
+-              src_fd = open(filename, O_RDONLY);
+-              if (src_fd < 0) {
+-                      bb_perror_msg("%s", filename);
+-                      return NULL;
+-              }
 -      }
 -
 -      /* figure specific hash algorithims */
@@ -67,7 +66,7 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -              bb_error_msg_and_die("algorithm not supported");
 -      }
 -
--      while (0 < (count = read(src_fd, in_buf, 4096))) {
+-      while (0 < (count = safe_read(src_fd, in_buf, 4096))) {
 -              update(in_buf, count, &context);
 -      }
 -
@@ -85,22 +84,22 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -      return hash_value;
 -}
 -
- /* This could become a common function for md5 as well, by using md5_stream */
- static int hash_files(int argc, char **argv, hash_algo_t hash_algo)
+ int md5_sha1_sum_main(int argc, char **argv)
  {
-diff -ruN busybox-1.2.0-orig/include/libbb.h busybox-1.2.0-libbb_hash/include/libbb.h
---- busybox-1.2.0-orig/include/libbb.h 2006-07-01 00:42:10.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/include/libbb.h   2006-07-22 17:01:06.000000000 +0200
-@@ -518,6 +518,8 @@
- extern int get_terminal_width_height(int fd, int *width, int *height);
- extern unsigned long get_ug_id(const char *s, long (*__bb_getxxnam)(const char *));
+       int return_value = EXIT_SUCCESS;
+diff -ruN busybox-1.3.1-orig/include/libbb.h busybox-1.3.1-913/include/libbb.h
+--- busybox-1.3.1-orig/include/libbb.h 2006-12-27 05:56:18.000000000 +0100
++++ busybox-1.3.1-913/include/libbb.h  2006-12-27 23:25:52.000000000 +0100
+@@ -528,6 +528,8 @@
+ extern const char bb_uuenc_tbl_std[];
+ void bb_uuencode(const unsigned char *s, char *store, const int length, const char *tbl);
  
 +typedef enum { HASH_SHA1, HASH_MD5 } hash_algo_t;
 +
- typedef struct _sha1_ctx_t_ {
+ typedef struct sha1_ctx_t {
        uint32_t count[2];
        uint32_t hash[5];
-@@ -542,6 +544,10 @@
+@@ -550,6 +552,10 @@
  void md5_hash(const void *data, size_t length, md5_ctx_t *ctx);
  void *md5_end(void *resbuf, md5_ctx_t *ctx);
  
@@ -108,13 +107,13 @@ diff -ruN busybox-1.2.0-orig/include/libbb.h busybox-1.2.0-libbb_hash/include/li
 +int hash_fd(int fd, hash_algo_t hash_algo, uint8_t *hash_value);
 +uint8_t *hash_file(const char *filename, hash_algo_t hash_algo);
 +
- extern uint32_t *bb_crc32_filltable (int endian);
+ uint32_t *crc32_filltable(int endian);
  
- #ifndef RB_POWER_OFF
-diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
---- busybox-1.2.0-orig/libbb/hash.c    1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.2.0-libbb_hash/libbb/hash.c      2006-07-22 17:07:34.000000000 +0200
-@@ -0,0 +1,100 @@
+diff -ruN busybox-1.3.1-orig/libbb/hash.c busybox-1.3.1-913/libbb/hash.c
+--- busybox-1.3.1-orig/libbb/hash.c    1970-01-01 01:00:00.000000000 +0100
++++ busybox-1.3.1-913/libbb/hash.c     2006-12-28 00:48:52.000000000 +0100
+@@ -0,0 +1,99 @@
 +/*
 + *  Copyright (C) 2003 Glenn L. McGrath
 + *  Copyright (C) 2003-2004 Erik Andersen
@@ -134,15 +133,12 @@ diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
 +
 +unsigned char *hash_bin_to_hex(unsigned char *hash_value, unsigned char hash_length)
 +{
-+      int x, len, max;
-+      unsigned char *hex_value;
-+
-+      max = (hash_length * 2) + 2;
-+      hex_value = xmalloc(max);
-+      for (x = len = 0; x < hash_length; x++) {
-+              len += snprintf((char*)(hex_value + len), max - len, "%02x", hash_value[x]);
++      int len = 0;
++      char *hex_value = xmalloc((hash_length * 2) + 2);
++      while (hash_length--) {
++              len += sprintf(hex_value + len, "%02x", *hash_value++);
 +      }
-+      return (hex_value);
++      return hex_value;
 +}
 +
 +int hash_fd(int fd, hash_algo_t hash_algo, uint8_t *hash_value)
@@ -168,7 +164,7 @@ diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
 +      }
 +
 +
-+      while (0 < (count = read(fd, in_buf, sizeof in_buf))) {
++      while (0 < (count = safe_read(fd, in_buf, sizeof in_buf))) {
 +              update(in_buf, count, &context);
 +              result += count;
 +      }
@@ -196,11 +192,13 @@ diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
 +              bb_error_msg_and_die("algotithm not supported");
 +      }
 +
-+      if (strcmp(filename, "-") == 0) {
-+              src_fd = STDIN_FILENO;
-+      } else if (0 > (src_fd = open(filename, O_RDONLY))) {
-+              bb_perror_msg("%s", filename);
-+              return NULL;
++      src_fd = STDIN_FILENO;
++      if (filename[0] != '-' || filename[1]) { /* not "-" */
++              src_fd = open(filename, O_RDONLY);
++              if (src_fd < 0) {
++                      bb_perror_msg("%s", filename);
++                      return NULL;
++              }
 +      }
 +
 +      if (hash_fd(src_fd, hash_algo, hash_buf) > 0) {
@@ -215,14 +213,14 @@ diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
 +
 +      return hash_value;
 +}
-diff -ruN busybox-1.2.0-orig/libbb/Makefile.in busybox-1.2.0-libbb_hash/libbb/Makefile.in
---- busybox-1.2.0-orig/libbb/Makefile.in       2006-07-01 00:42:08.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/libbb/Makefile.in 2006-07-22 16:51:47.000000000 +0200
-@@ -11,6 +11,7 @@
- LIBBB-n:=
- LIBBB-y:= \
-+      hash.c \
-       bb_asprintf.c ask_confirmation.c change_identity.c chomp.c \
-       compare_string_array.c concat_path_file.c copy_file.c copyfd.c \
-       crc32.c create_icmp_socket.c create_icmp6_socket.c \
+diff -ruN busybox-1.3.1-orig/libbb/Kbuild busybox-1.3.1-913/libbb/Kbuild
+--- busybox-1.3.1-orig/libbb/Kbuild    2006-12-27 05:55:04.000000000 +0100
++++ busybox-1.3.1-913/libbb/Kbuild     2006-12-27 23:31:20.000000000 +0100
+@@ -37,6 +37,7 @@
+ lib-y += get_last_path_component.o
+ lib-y += get_line_from_file.o
+ lib-y += getopt32.o
++lib-y += hash.o
+ lib-y += herror_msg.o
+ lib-y += herror_msg_and_die.o
+ lib-y += human_readable.o