perf: add dependency on !LINUX_3_18 to fix builds
[openwrt/staging/mkresin.git] / package / devel / perf / Makefile
index 97eecd715d1c2bff7c783f6e330566406f469a03..db6838787c947522fb950e1422d159cd0a34abe6 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump
+  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -59,7 +59,7 @@ MAKE_FLAGS = \
        prefix=/usr
 
 ifdef CONFIG_USE_MUSL
- MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+ MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
 endif
 
 define Build/Compile