perf: add dependency on !LINUX_3_18 to fix builds
[openwrt/staging/mkresin.git] / package / devel / perf / Makefile
index d6db053173bbb4b6f1ba563386a3dac8c3b2731d..db6838787c947522fb950e1422d159cd0a34abe6 100644 (file)
@@ -14,6 +14,7 @@ PKG_RELEASE:=2
 
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
 # Perf's makefile and headers are not relocatable and must be built from the
 # Linux sources directory
@@ -24,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -57,6 +58,10 @@ MAKE_FLAGS = \
        WERROR=0 \
        prefix=/usr
 
+ifdef CONFIG_USE_MUSL
+ MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
+
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
                -C $(PKG_BUILD_DIR) \