add a default for PKG_BUILD_DIR and PKG_INSTALL_DIR (will use KERNEL_BUILD_DIR if...
[openwrt/staging/mkresin.git] / package / iptables / Makefile
index 862797e315a1b3d1ff9708ae71802dbde6bff67d..c7f73f1ccf08d36347dff998d580b2a2b02ad49f 100644 (file)
@@ -21,9 +21,6 @@ PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
 PKG_MD5SUM:=00fb916fa8040ca992a5ace56d905ea5
 PKG_CAT:=bzcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
@@ -74,7 +71,7 @@ endef
 
 define Package/iptables-mod-imq
   $(call Package/iptables/Default)
-  DEPENDS:=iptables
+  DEPENDS:=iptables +kmod-ipt-imq
   TITLE:=IMQ support
   DESCRIPTION:=\
        iptables extension for IMQ support.\\\
@@ -91,6 +88,7 @@ define Package/iptables-mod-ipopt
        iptables extensions for matching/changing IP packet options.\\\
        \\\
        Includes: \\\
+       - libipt_CLASSIFY \\\
        - libipt_dscp/DSCP \\\
        - libipt_ecn/ECN \\\
        - libipt_length \\\
@@ -162,7 +160,11 @@ define Package/ip6tables
   TITLE:=IPv6 firewall administration tool
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               clean
 endef
 
 define Build/Compile
@@ -173,7 +175,7 @@ define Build/Compile
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install install-devel
+               all install
 endef
 
 define Build/InstallDev
@@ -182,13 +184,21 @@ define Build/InstallDev
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(STAGING_DIR)" \
-               install install-devel
+               install-devel
        $(CP) $(PKG_BUILD_DIR)/include $(STAGING_DIR)/usr
+       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(STAGING_DIR)/usr/lib
 endef
 
 define Build/UninstallDev
        rm -rf $(STAGING_DIR)/usr/include/libipq.h
+       rm -rf $(STAGING_DIR)/usr/include/libipulog
+       rm -rf $(STAGING_DIR)/usr/include/libipq
+       rm -rf $(STAGING_DIR)/usr/include/libiptc
+       rm -rf $(STAGING_DIR)/usr/include/linux/netfilter*
+       rm -rf $(STAGING_DIR)/usr/include/iptables*
+       rm -rf $(STAGING_DIR)/usr/include/ip6tables*
        rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+       rm -rf $(STAGING_DIR)/usr/lib/libiptc.a
 endef
 
 define Package/iptables/install
@@ -233,7 +243,8 @@ define BuildPlugin
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
-L7_INSTALL:=mkdir -p $$(1)/etc/l7-protocols; \
+L7_INSTALL:=\
+       $(INSTALL_DIR) $$(1)/etc/l7-protocols; \
        $(CP) files/l7/*.pat $$(1)/etc/l7-protocols/
 
 $(eval $(call BuildPackage,iptables))