include/feeds.mk: rework generation of opkg distfeeds.conf
[openwrt/staging/mkresin.git] / package / kernel / linux / modules / wireless.mk
index 72e2bf477b2f8340e9970c60c97a7ebe5a300dab..7b1c6635674b6b9fc1de39a4e173bccdc13b3462 100644 (file)
@@ -41,3 +41,24 @@ define KernelPackage/net-rtl8192su/description
 endef
 
 $(eval $(call KernelPackage,net-rtl8192su))
+
+
+define KernelPackage/owl-loader
+  SUBMENU:=$(WIRELESS_MENU)
+  TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
+  DEPENDS:=@PCI_SUPPORT
+  KCONFIG:=CONFIG_OWL_LOADER
+  FILES:=$(LINUX_DIR)/drivers/misc/owl-loader.ko
+  AUTOLOAD:=$(call AutoProbe,owl-loader)
+endef
+
+define KernelPackage/owl-loader/description
+  Kernel module that helps to initialize certain Qualcomm
+  Atheros' PCI(e) Wifi chips, which have the init data
+  (which contains the PCI device ID for example) stored
+  together with the calibration data in the file system.
+
+  This is necessary for devices like the Cisco Meraki Z1.
+endef
+
+$(eval $(call KernelPackage,owl-loader))