Fix compilation of lm77 module (#3447)
[openwrt/staging/mkresin.git] / package / kernel / modules / hwmon.mk
index cf5571c880914bac5a7061c1eaeee91aa09008b1..8ecf6cc8a91367d004e8a28fb33ed2978feb52be 100644 (file)
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,hwmon-core))
 define KernelPackage/hwmon-lm77
   SUBMENU:=$(HWMON_MENU)
   TITLE:=LM77 monitoring support
-  DEPENDS:=kmod-hwmon-core
+  DEPENDS:=kmod-hwmon-core kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM77
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm77)