openvpn: fix compile error with musl
[openwrt/staging/mkresin.git] / package / network / services / openvpn / Makefile
index 8e1ccaeb2e8549d202d4eff626f0b1047b10ed46..1e0c7faf29f2e1415136177e9c400b96da99b3cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2012 OpenWrt.org
+# Copyright (C) 2010-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
 
-PKG_VERSION:=2.3.0
-PKG_RELEASE=1
+PKG_VERSION:=2.3.4
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=04d47237907faabe9d046970ffe44b2e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -65,7 +66,7 @@ CONFIGURE_VARS += \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-small \
+               $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SMALL),--enable-small) \
                --disable-selinux \
                --disable-systemd \
                --disable-plugins \