fix for ticket:989
[openwrt/staging/mkresin.git] / package / openssl / Makefile
index 827c4415c00104793343a9e8a367204cc5e37f96..9c1f6bf7f8078a99ce7ef7464b3db192b09b6f38 100644 (file)
@@ -62,8 +62,11 @@ define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-rmd160 no-aes192
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic no-engines
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+                                       no-engines no-sse2 no-perlasm
+
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \