procd: fix uci_validation
[openwrt/staging/mkresin.git] / package / system / procd / Makefile
index 27879e8443d31b0ef1214947059c3c0195662783..30bcd2a7f2cf1a80ed71d0b1d8bbb426ed2dec59 100644 (file)
@@ -1,13 +1,21 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-07-08
+PKG_VERSION:=2014-06-27
+
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=725e6bbbe403a950c0ddcd23cb521ffefa705c7d
+PKG_SOURCE_VERSION:=8e12022c3d00f8acca4471016d71794988113c34
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -24,18 +32,32 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
   TITLE:=OpenWrt system process manager
 endef
 
+define Package/procd-nand
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@NAND_SUPPORT +ubi-utils
+  TITLE:=OpenWrt sysupgrade nand helper
+endef
+
 define Package/procd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions
 
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
-       $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
+       $(INSTALL_BIN) ./files/reload_config $(1)/sbin/
        $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
        $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
-       ln -s /sbin/procd $(1)/sbin/init
+endef
+
+define Package/procd-nand/install
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib/upgrade
+
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/upgraded $(1)/sbin/
+       $(INSTALL_DATA) ./files/nand.sh $(1)/lib/upgrade/
 endef
 
 $(eval $(call BuildPackage,procd))
+$(eval $(call BuildPackage,procd-nand))