procd: update to latest git HEAD
[openwrt/staging/mkresin.git] / package / system / procd / Makefile
index 14e60e308dc46b0fe3fd06a0b3c7c7e0a6204035..8a6c5dc53c7b355e70982ed065ec2f9b4d1d9985 100644 (file)
@@ -1,14 +1,21 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-11-19
+PKG_VERSION:=2014-10-06
 
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-2
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=84a6256a01c45079e8a27e37a0fe8715f2254c7b
+PKG_SOURCE_VERSION:=50e58ba53e75f5fb7c30e31cb235b5f7d160c47d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -25,12 +32,19 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
   TITLE:=OpenWrt system process manager
 endef
 
+define Package/procd-nand
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@NAND_SUPPORT +ubi-utils
+  TITLE:=OpenWrt sysupgrade nand helper
+endef
+
 define Package/procd/install
-       $(INSTALL_DIR) $(1)/sbin  $(1)/etc $(1)/lib/functions
+       $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions
 
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
        $(INSTALL_BIN) ./files/reload_config $(1)/sbin/
@@ -38,4 +52,12 @@ define Package/procd/install
        $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
 endef
 
+define Package/procd-nand/install
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib/upgrade
+
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/upgraded $(1)/sbin/
+       $(INSTALL_DATA) ./files/nand.sh $(1)/lib/upgrade/
+endef
+
 $(eval $(call BuildPackage,procd))
+$(eval $(call BuildPackage,procd-nand))