major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/mkresin.git] / target / linux / amcc / Makefile
index 4dd366caa9ac34685be7fd25397def5e4d1e48fe..a35783be4197be79a82547a377fb98b2c41f2ffe 100644 (file)
@@ -13,13 +13,13 @@ FEATURES:=jffs2
 
 LINUX_VERSION:=2.6.21.5
 
+include $(INCLUDE_DIR)/target.mk
+
 define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))