ath79: Add support for Ubiquiti NanoBeam AC
[openwrt/staging/mkresin.git] / target / linux / ath79 / image / generic-ubnt.mk
index b7e867d8bf2e9dcdbdc930d149793522ab3b3061..8fddc0f1d0e327799cc67328ca2804fc87568160 100644 (file)
@@ -129,6 +129,15 @@ define Device/ubnt_lap-120
 endef
 TARGET_DEVICES += ubnt_lap-120
 
+define Device/ubnt_nanobeam-ac
+  $(Device/ubnt-wa)
+  DEVICE_TITLE := Ubiquiti NanoBeam AC
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15744k
+  IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_nanobeam-ac
+
 define Device/ubnt_nanostation-ac
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti Nanostation AC