brcm63xx: initial support for Sky SR102 router
[openwrt/staging/mkresin.git] / target / linux / brcm63xx / image / bcm63xx.mk
index b9ecd5406433cebdb4d0305147aa0578c762fbd1..6a2a9bfb4ac06082fa07c6f0ac706216ff8e2fd8 100644 (file)
@@ -1020,6 +1020,18 @@ define Device/NEUFBOX6
 endef
 TARGET_DEVICES += NEUFBOX6
 
+define Device/SR102
+  $(Device/bcm63xx)
+  DEVICE_TITLE := SKY-SR102
+  DEVICE_DTS := sr102
+  CFE_BOARD_ID := BSKYB_63168
+  CFE_CHIP_ID := 63268
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
+  DEVICE_PACKAGES := \
+    $(B43_PACKAGES) $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += SR102
+
 ### T-Com ###
 define Device/SPW303V
   $(Device/bcm63xx)