kernel: update 3.10.36->3.10.44
[openwrt/staging/mkresin.git] / target / linux / cns21xx / Makefile
index e0205f74abd7ba323a646f77e94443a8953445c8..2b0d7f2edf3e01c79a702d26eb966edabcb3ab29 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=cns21xx
-BOARDNAME:=Cavium Networks CNS21xx
-FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+BOARDNAME:=Cavium Networks Econa CNS21xx
+FEATURES:=squashfs
+CPU_TYPE:=fa526
 
-LINUX_VERSION:=2.6.36.4
+LINUX_VERSION:=3.10.44
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
+KERNELNAME:="zImage uImage"
+
 $(eval $(call BuildTarget))