kernel: refresh generic 3.10 patches
[openwrt/staging/mkresin.git] / target / linux / generic / patches-3.10 / 643-bridge_remove_ipv6_dependency.patch
index 407c980e014bbdb695fe48199791c672d14d9082..7bb0ee8d5f0fda1b70de1a988a6d3ced14c74599 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o 
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
@@ -49,7 +49,7 @@
  
  int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
                      unsigned char banned_flags)
-@@ -5173,6 +5172,9 @@ int __init addrconf_init(void)
+@@ -5183,6 +5182,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -5191,6 +5193,9 @@ void addrconf_cleanup(void)
+@@ -5201,6 +5203,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;