fix lantiq image makefile to represent new split between ar9 and danube
[openwrt/staging/mkresin.git] / target / linux / lantiq / image / Makefile
index e73ee1936db7f2ab76debe2ad9a13e3cc96b06a8..43ad0e88f35ae633a64efbc2f7619db7493e0ca3 100644 (file)
@@ -136,6 +136,14 @@ define Image/Build/Profile/ARV752DPW22
        $(call Image/Build/$(1),$(1),ARV752DPW22)
 endef
 
+define Image/BuildKernel/Profile/GIGASX76X
+       $(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/GIGASX76X
+       $(call Image/Build/$(1),$(1),GIGASX76X)
+endef
+
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
        $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
@@ -149,6 +157,7 @@ define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
        $(call Image/BuildKernel/Template,NONE)
 endef
 
@@ -165,12 +174,34 @@ define Image/Build/Profile/Generic
        $(call Image/Build/$(1),$(1),ARV7518PW)
        $(call Image/Build/$(1),$(1),ARV752DPW)
        $(call Image/Build/$(1),$(1),ARV752DPW22)
+       $(call Image/Build/$(1),$(1),GIGASX76X)
+       $(call Image/Build/$(1),$(1),NONE)
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+endef
+endif
+
+ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/DGN3500B
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+       $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
+define Image/BuildKernel/Profile/Generic
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,NONE)
+endef
+
+define Image/Build/Profile/Generic
+       $(call Image/Build/$(1),$(1),DGN3500B)
        $(call Image/Build/$(1),$(1),NONE)
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
 endef
 endif
 
-ifeq ($(CONFIG_TARGET_lantiq_falcon),y)
+ifeq ($(CONFIG_TARGET_lantiq_falcon)$(CONFIG_TARGET_lantiq_falcon_stable),y)
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
        $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))