kernel: bump 4.9 to 4.9.63
[openwrt/staging/mkresin.git] / target / linux / layerscape / patches-4.9 / 706-fsl_ppfe-support-layercape.patch
index 844475adfefc8fe8b46c8fa8f3accad36604f4f3..4104272eff4da9d4d77ea0a3e88017fd02c37981 100644 (file)
@@ -78,9 +78,6 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  create mode 100644 drivers/staging/fsl_ppfe/pfe_sysfs.c
  create mode 100644 drivers/staging/fsl_ppfe/pfe_sysfs.h
 
-diff --git a/drivers/staging/fsl_ppfe/Kconfig b/drivers/staging/fsl_ppfe/Kconfig
-new file mode 100644
-index 00000000..e4096435
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/Kconfig
 @@ -0,0 +1,20 @@
@@ -104,9 +101,6 @@ index 00000000..e4096435
 +      UTIL PE has to be enabled only if required.
 +
 +endif # FSL_PPFE
-diff --git a/drivers/staging/fsl_ppfe/Makefile b/drivers/staging/fsl_ppfe/Makefile
-new file mode 100644
-index 00000000..07cd351b
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/Makefile
 @@ -0,0 +1,19 @@
@@ -129,17 +123,11 @@ index 00000000..07cd351b
 +      pfe_debugfs.o \
 +      pfe_ls1012a_platform.o \
 +      pfe_hal.o
-diff --git a/drivers/staging/fsl_ppfe/TODO b/drivers/staging/fsl_ppfe/TODO
-new file mode 100644
-index 00000000..43c48ccd
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/TODO
 @@ -0,0 +1,2 @@
 +TODO:
 +      - provide pfe pe monitoring support
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus.h b/drivers/staging/fsl_ppfe/include/pfe/cbus.h
-new file mode 100644
-index 00000000..04503d28
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus.h
 @@ -0,0 +1,78 @@
@@ -221,9 +209,6 @@ index 00000000..04503d28
 +#define DDR_BUF_SIZE  BIT(DDR_BUF_SIZE_LN2)
 +
 +#endif /* _CBUS_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/bmu.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/bmu.h
-new file mode 100644
-index 00000000..87738ca3
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/bmu.h
 @@ -0,0 +1,55 @@
@@ -282,9 +267,6 @@ index 00000000..87738ca3
 +#define BMU2_MCAST_ALLOC_CTRL (BMU2_BASE_ADDR + BMU_MCAST_ALLOC_CTRL)
 +
 +#endif /* _BMU_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/class_csr.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/class_csr.h
-new file mode 100644
-index 00000000..e4dadff5
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/class_csr.h
 @@ -0,0 +1,289 @@
@@ -577,9 +559,6 @@ index 00000000..e4dadff5
 +};
 +
 +#endif /* _CLASS_CSR_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/emac_mtip.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/emac_mtip.h
-new file mode 100644
-index 00000000..9c5d7919
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/emac_mtip.h
 @@ -0,0 +1,242 @@
@@ -825,9 +804,6 @@ index 00000000..9c5d7919
 +#define EMAC_SPEC_ADDR_MAX    4
 +
 +#endif /* _EMAC_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/gpi.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/gpi.h
-new file mode 100644
-index 00000000..7b295830
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/gpi.h
 @@ -0,0 +1,86 @@
@@ -917,9 +893,6 @@ index 00000000..7b295830
 +#define EGPI_PAUSE_TIME               0x000007D0
 +#define EGPI_PAUSE_ENABLE     0x40000000
 +#endif /* _GPI_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/hif.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/hif.h
-new file mode 100644
-index 00000000..71cf81a7
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/hif.h
 @@ -0,0 +1,100 @@
@@ -1023,9 +996,6 @@ index 00000000..71cf81a7
 +#define PROC_ID(id)   ((id) << 18)
 +
 +#endif /* _HIF_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/hif_nocpy.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/hif_nocpy.h
-new file mode 100644
-index 00000000..3d4d43ce
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/hif_nocpy.h
 @@ -0,0 +1,50 @@
@@ -1079,9 +1049,6 @@ index 00000000..3d4d43ce
 +#define HIF_NOCPY_INT_COAL    (HIF_NOCPY_BASE_ADDR + 0x90)
 +
 +#endif /* _HIF_NOCPY_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/tmu_csr.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/tmu_csr.h
-new file mode 100644
-index 00000000..05f3d681
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/tmu_csr.h
 @@ -0,0 +1,168 @@
@@ -1253,9 +1220,6 @@ index 00000000..05f3d681
 +#define DEFAULT_TMU3_QDEPTH   127
 +
 +#endif /* _TMU_CSR_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/cbus/util_csr.h b/drivers/staging/fsl_ppfe/include/pfe/cbus/util_csr.h
-new file mode 100644
-index 00000000..ae623cda
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/cbus/util_csr.h
 @@ -0,0 +1,61 @@
@@ -1320,9 +1284,6 @@ index 00000000..ae623cda
 +};
 +
 +#endif /* _UTIL_CSR_H_ */
-diff --git a/drivers/staging/fsl_ppfe/include/pfe/pfe.h b/drivers/staging/fsl_ppfe/include/pfe/pfe.h
-new file mode 100644
-index 00000000..d93ae4c6
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/include/pfe/pfe.h
 @@ -0,0 +1,372 @@
@@ -1698,9 +1659,6 @@ index 00000000..d93ae4c6
 +}
 +
 +#endif /* _PFE_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_ctrl.c b/drivers/staging/fsl_ppfe/pfe_ctrl.c
-new file mode 100644
-index 00000000..dfa8547c
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_ctrl.c
 @@ -0,0 +1,238 @@
@@ -1942,9 +1900,6 @@ index 00000000..dfa8547c
 +{
 +      pr_info("%s\n", __func__);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_ctrl.h b/drivers/staging/fsl_ppfe/pfe_ctrl.h
-new file mode 100644
-index 00000000..22115c76
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_ctrl.h
 @@ -0,0 +1,112 @@
@@ -2060,9 +2015,6 @@ index 00000000..22115c76
 +int relax(unsigned long end);
 +
 +#endif /* _PFE_CTRL_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_debugfs.c b/drivers/staging/fsl_ppfe/pfe_debugfs.c
-new file mode 100644
-index 00000000..4156610d
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_debugfs.c
 @@ -0,0 +1,111 @@
@@ -2177,9 +2129,6 @@ index 00000000..4156610d
 +{
 +      debugfs_remove_recursive(pfe->dentry);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_debugfs.h b/drivers/staging/fsl_ppfe/pfe_debugfs.h
-new file mode 100644
-index 00000000..301d9fc2
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_debugfs.h
 @@ -0,0 +1,25 @@
@@ -2208,9 +2157,6 @@ index 00000000..301d9fc2
 +void pfe_debugfs_exit(struct pfe *pfe);
 +
 +#endif /* _PFE_DEBUGFS_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_eth.c b/drivers/staging/fsl_ppfe/pfe_eth.c
-new file mode 100644
-index 00000000..02cd7c52
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_eth.c
 @@ -0,0 +1,2434 @@
@@ -4648,9 +4594,6 @@ index 00000000..02cd7c52
 +      for (ii = NUM_GEMAC_SUPPORT - 1; ii >= 0; ii--)
 +              pfe_eth_exit_one(pfe->eth.eth_priv[ii]);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_eth.h b/drivers/staging/fsl_ppfe/pfe_eth.h
-new file mode 100644
-index 00000000..721bef3e
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_eth.h
 @@ -0,0 +1,184 @@
@@ -4838,9 +4781,6 @@ index 00000000..721bef3e
 +int pfe_eth_mdio_reset(struct mii_bus *bus);
 +
 +#endif /* _PFE_ETH_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_firmware.c b/drivers/staging/fsl_ppfe/pfe_firmware.c
-new file mode 100644
-index 00000000..47462b9f
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_firmware.c
 @@ -0,0 +1,314 @@
@@ -5158,9 +5098,6 @@ index 00000000..47462b9f
 +      util_disable();
 +#endif
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_firmware.h b/drivers/staging/fsl_ppfe/pfe_firmware.h
-new file mode 100644
-index 00000000..5ade848b
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_firmware.h
 @@ -0,0 +1,32 @@
@@ -5196,9 +5133,6 @@ index 00000000..5ade848b
 +void pfe_firmware_exit(struct pfe *pfe);
 +
 +#endif /* _PFE_FIRMWARE_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_hal.c b/drivers/staging/fsl_ppfe/pfe_hal.c
-new file mode 100644
-index 00000000..0915034b
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hal.c
 @@ -0,0 +1,1516 @@
@@ -6718,9 +6652,6 @@ index 00000000..0915034b
 +      hif_int &= HIF_RXPKT_INT_EN;
 +      writel(hif_int, HIF_INT_ENABLE);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_hif.c b/drivers/staging/fsl_ppfe/pfe_hif.c
-new file mode 100644
-index 00000000..6835e140
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hif.c
 @@ -0,0 +1,1072 @@
@@ -7796,9 +7727,6 @@ index 00000000..6835e140
 +      pfe_hif_release_buffers(hif);
 +      pfe_hif_free_descr(hif);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_hif.h b/drivers/staging/fsl_ppfe/pfe_hif.h
-new file mode 100644
-index 00000000..6e36f0c1
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hif.h
 @@ -0,0 +1,211 @@
@@ -8013,9 +7941,6 @@ index 00000000..6e36f0c1
 +#define __memcpy(dst, src, len)               memcpy(dst, src, len)
 +
 +#endif /* _PFE_HIF_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_hif_lib.c b/drivers/staging/fsl_ppfe/pfe_hif_lib.c
-new file mode 100644
-index 00000000..837eaa24
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hif_lib.c
 @@ -0,0 +1,601 @@
@@ -8620,9 +8545,6 @@ index 00000000..837eaa24
 +
 +      pfe_hif_shm_clean(pfe->hif.shm);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_hif_lib.h b/drivers/staging/fsl_ppfe/pfe_hif_lib.h
-new file mode 100644
-index 00000000..49e7b5f1
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hif_lib.h
 @@ -0,0 +1,239 @@
@@ -8865,9 +8787,6 @@ index 00000000..49e7b5f1
 +      })
 +
 +#endif /* _PFE_HIF_LIB_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_hw.c b/drivers/staging/fsl_ppfe/pfe_hw.c
-new file mode 100644
-index 00000000..16ea2c65
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hw.c
 @@ -0,0 +1,176 @@
@@ -9047,9 +8966,6 @@ index 00000000..16ea2c65
 +      bmu_disable(BMU2_BASE_ADDR);
 +      bmu_reset(BMU2_BASE_ADDR);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_hw.h b/drivers/staging/fsl_ppfe/pfe_hw.h
-new file mode 100644
-index 00000000..53b5fe14
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_hw.h
 @@ -0,0 +1,27 @@
@@ -9080,9 +8996,6 @@ index 00000000..53b5fe14
 +void pfe_hw_exit(struct pfe *pfe);
 +
 +#endif /* _PFE_HW_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_ls1012a_platform.c b/drivers/staging/fsl_ppfe/pfe_ls1012a_platform.c
-new file mode 100644
-index 00000000..c579eb58
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_ls1012a_platform.c
 @@ -0,0 +1,394 @@
@@ -9480,9 +9393,6 @@ index 00000000..c579eb58
 +MODULE_LICENSE("GPL");
 +MODULE_DESCRIPTION("PFE Ethernet driver");
 +MODULE_AUTHOR("NXP DNCPE");
-diff --git a/drivers/staging/fsl_ppfe/pfe_mod.c b/drivers/staging/fsl_ppfe/pfe_mod.c
-new file mode 100644
-index 00000000..d5ba56a3
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_mod.c
 @@ -0,0 +1,141 @@
@@ -9627,9 +9537,6 @@ index 00000000..d5ba56a3
 +
 +      return 0;
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_mod.h b/drivers/staging/fsl_ppfe/pfe_mod.h
-new file mode 100644
-index 00000000..3012f17f
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_mod.h
 @@ -0,0 +1,112 @@
@@ -9745,9 +9652,6 @@ index 00000000..3012f17f
 +#define BMU1_LMEM_SIZE                (LMEM_BUF_SIZE * BMU1_BUF_COUNT)
 +
 +#endif /* _PFE_MOD_H */
-diff --git a/drivers/staging/fsl_ppfe/pfe_perfmon.h b/drivers/staging/fsl_ppfe/pfe_perfmon.h
-new file mode 100644
-index 00000000..84908121
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_perfmon.h
 @@ -0,0 +1,38 @@
@@ -9789,9 +9693,6 @@ index 00000000..84908121
 +void pfe_perfmon_exit(struct pfe *pfe);
 +
 +#endif /* _PFE_PERFMON_H_ */
-diff --git a/drivers/staging/fsl_ppfe/pfe_sysfs.c b/drivers/staging/fsl_ppfe/pfe_sysfs.c
-new file mode 100644
-index 00000000..2a763844
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_sysfs.c
 @@ -0,0 +1,818 @@
@@ -10613,9 +10514,6 @@ index 00000000..2a763844
 +      device_remove_file(pfe->dev, &dev_attr_tmu);
 +      device_remove_file(pfe->dev, &dev_attr_class);
 +}
-diff --git a/drivers/staging/fsl_ppfe/pfe_sysfs.h b/drivers/staging/fsl_ppfe/pfe_sysfs.h
-new file mode 100644
-index 00000000..4fb39c93
 --- /dev/null
 +++ b/drivers/staging/fsl_ppfe/pfe_sysfs.h
 @@ -0,0 +1,29 @@
@@ -10648,6 +10546,3 @@ index 00000000..4fb39c93
 +void pfe_sysfs_exit(struct pfe *pfe);
 +
 +#endif /* _PFE_SYSFS_H_ */
--- 
-2.14.1
-