kernel: update linux 3.8 to 3.8.7
[openwrt/staging/mkresin.git] / target / linux / ramips / Makefile
index 3630c78f161fbb56997b26a30aa7ef2e6fbd6e96..b78a00174cc1e288661141aeb5b18045a8bc1ebe 100644 (file)
@@ -10,16 +10,16 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.8.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
        kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc swconfig
+       kmod-rt2800-pci wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.