kernel: update 3.10 to 3.10.13
[openwrt/staging/mkresin.git] / target / linux / ramips / Makefile
index 0d82260acf3664f058261d1d0d98dde24d72b1cb..fec7ddbc9319ec2a3c3c2e1d2e13a002bbc0e2c9 100644 (file)
@@ -8,20 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt305x rt3883 mt7620a rt288x
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=2.6.39.4
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
-       kmod-button-hotplug kmod-rt2800-pci wpad-mini maccalc
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-keys-polled kmod-button-hotplug \
+       kmod-rt2800-pci wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))