ath79: ar934x: Update dts for current ag71xx driver
[openwrt/staging/mkresin.git] / tools / bison / Makefile
index 01820e2755009d4d53656c5175e5b471fbdbff50..68e06ae33b566df5c20388acc9b83d1cc6ab19f2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.4.3
+PKG_VERSION:=3.0.5
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=c1d3ea81bc370dbd43b6f0b2cd21287e
-PKG_CAT:=bzcat
+PKG_HASH:=075cef2e814642e30e10e8155e93022e4a91ca38a65aa1d5467d4e969f97f338
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -21,4 +22,9 @@ define Host/Clean
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))