build: add the + token to any commands that can pass through the jobserver, fixes...
[openwrt/staging/mkresin.git] / tools / cmake / Makefile
index d5e885ca3352fbe7a9aed0fd1e7dcd1cc9a9f3ad..47df5d961e3deb9c9c33af5514ae2a40c9f67efa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=2.8.4
+PKG_VERSION:=2.8.7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
-PKG_MD5SUM:=209b7d1d04b2e00986538d74ba764fcf
+PKG_MD5SUM:=e1b237aeaed880f65dec9c20602452f6
+
+HOST_BUILD_PARALLEL:=1
+HOST_CONFIGURE_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
+
 $(eval $(call HostBuild))