ramips: define image recipe for uncompressed uimage with loader
authorChuanhong Guo <gch981213@gmail.com>
Tue, 14 Apr 2020 04:01:50 +0000 (12:01 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Tue, 14 Apr 2020 04:01:50 +0000 (12:01 +0800)
Some devices have bootloaders with broken lzma code resulting in failed
decompression or corrupted kernel code.
This image recipe allows to sacrifice 5KB for OpenWrt LZMA loader and
take over the task of decompress kernel.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/image/Makefile

index bc5de7d8d009c6ca82f888587e0e1ebd64fd5b88..a966ba43490923cbff1b974615ef293cd27dc696 100644 (file)
@@ -37,6 +37,11 @@ define Device/Default
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
 endef
 
+define Device/uimage-lzma-loader
+  LOADER_TYPE := bin
+  KERNEL := $(KERNEL_DTB) | loader-kernel | uImage none
+endef
+
 define Device/seama
   SEAMA_MTDBLOCK := 2
   IMAGES += factory.bin