mediatek: drop redmi-ax6000 variant with modified env
authorChuanhong Guo <gch981213@gmail.com>
Fri, 30 Dec 2022 07:55:56 +0000 (15:55 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Fri, 30 Dec 2022 08:11:59 +0000 (16:11 +0800)
This variant uses xiaomi factory u-boot and modified u-boot-env &
bootcmd.
By modifying uboot-env, the xiaomi firmware recovery provided in
the vendor u-boot doesn't work anymore. It's possible to put
u-boot into a state where it refuese to take any serial input.
If the u-boot is in this state, users can't restore their
firmware without taking the flash off the board.
We now have a -stock variant where the vendor u-boot is used in
a way that xiaomi firmware recovery still works, and a -ubootmod
variant where we get rid of all xiaomi components, have more
usable space and no uart console lock. These two should cover all
use cases and we don't need this variant anymore.
Drop this redmi-ax6000 variant. Existing users of this variant
should perform a u-boot mod or restore to the -stock layout.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
package/boot/uboot-envtools/files/mediatek_filogic
target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts [deleted file]
target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
target/linux/mediatek/filogic/base-files/etc/board.d/02_network
target/linux/mediatek/image/filogic.mk

index bdff66a17bc858e9221bfb8285263fc4fb08f445..787fac8dd6796b6ca5ad7a2d2f85c9278ce9d9fe 100644 (file)
@@ -34,7 +34,6 @@ bananapi,bpi-r3)
                ;;
        esac
        ;;
-xiaomi,redmi-router-ax6000|\
 xiaomi,redmi-router-ax6000-stock)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x10000" "0x20000"
        ubootenv_add_uci_sys_config "/dev/mtd2" "0x0" "0x10000" "0x20000"
diff --git a/target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts b/target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts
deleted file mode 100644 (file)
index 6240733..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-// SPDX-License-Identifier: (GPL-2.0 OR MIT)
-
-/dts-v1/;
-#include "mt7986a-xiaomi-redmi-router-ax6000.dtsi"
-
-/ {
-       model = "Xiaomi Redmi Router AX6000";
-       compatible = "xiaomi,redmi-router-ax6000", "mediatek,mt7986a";
-};
-
-&spi_nand_flash {
-       mediatek,nmbm;
-       mediatek,bmt-max-ratio = <1>;
-       mediatek,bmt-max-reserved-blocks = <64>;
-};
-
-&partitions {
-       partition@580000 {
-               label = "crash";
-               reg = <0x580000 0x40000>;
-               read-only;
-       };
-
-       partition@5c0000 {
-               label = "crash_log";
-               reg = <0x5c0000 0x40000>;
-               read-only;
-       };
-
-       /* ubi partition is the result of squashing
-        * consecutive stock partitions:
-        * - ubi
-        * - ubi1
-        * - overlay
-        */
-       partition@600000 {
-               label = "ubi";
-               reg = <0x600000 0x6e00000>;
-       };
-
-       /* last 12 MiB is reserved for NMBM bad block table */
-};
index d85b12fb6654362df28f7754cc342d28976136a6..6b922de16354702106ae62e68fcfeee56c1c5bc7 100644 (file)
@@ -6,7 +6,6 @@ board=$(board_name)
 board_config_update
 
 case $board in
-xiaomi,redmi-router-ax6000|\
 xiaomi,redmi-router-ax6000-stock|\
 xiaomi,redmi-router-ax6000-ubootmod)
        ucidef_set_led_netdev "wan" "wan" "rgb:network" "wan"
index 608161f0ad97dc24be0fdef24210933470dbc905..13f52587c35f5d8ba290489bbe7fe8e93fed859a 100644 (file)
@@ -16,7 +16,6 @@ mediatek_setup_interfaces()
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 sfp2" "eth1 wan"
                ucidef_set_interface_macaddr "wan" "$(macaddr_add $(cat /sys/class/net/eth0/address) 1)"
                ;;
-       xiaomi,redmi-router-ax6000|\
        xiaomi,redmi-router-ax6000-stock|\
        xiaomi,redmi-router-ax6000-ubootmod)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" wan
@@ -35,7 +34,6 @@ mediatek_setup_macs()
        local label_mac=""
 
        case $board in
-       xiaomi,redmi-router-ax6000|\
        xiaomi,redmi-router-ax6000-stock|\
        xiaomi,redmi-router-ax6000-ubootmod)
                wan_mac=$(mtd_get_mac_ascii Bdata ethaddr_wan)
index 4b16cff56ef4e4493bb7ce780d213c19b6e7ab44..5c223d04ff132a7bf92d9c60154b5f3773ccd949 100644 (file)
@@ -125,21 +125,6 @@ define Device/mediatek_mt7986b-rfb
 endef
 TARGET_DEVICES += mediatek_mt7986b-rfb
 
-define Device/xiaomi_redmi-router-ax6000
-  DEVICE_VENDOR := Xiaomi
-  DEVICE_MODEL := Redmi Router AX6000
-  DEVICE_DTS := mt7986a-xiaomi-redmi-router-ax6000
-  DEVICE_DTS_DIR := ../dts
-  DEVICE_PACKAGES := kmod-leds-ws2812b
-  KERNEL_LOADADDR := 0x48000000
-  UBINIZE_OPTS := -E 5
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  KERNEL_IN_UBI := 1
-  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-endef
-TARGET_DEVICES += xiaomi_redmi-router-ax6000
-
 define Device/xiaomi_redmi-router-ax6000-stock
   DEVICE_VENDOR := Xiaomi
   DEVICE_MODEL := Redmi Router AX6000 (stock layout)