uboot-mediatek: mark MT7621 variants as @BROKEN
authorDaniel Golle <daniel@makrotopia.org>
Tue, 12 Jul 2022 18:55:38 +0000 (19:55 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 12 Jul 2022 18:58:13 +0000 (19:58 +0100)
Building U-Boot for the MT7621 SoC requires binman, a Python-based
host tool to generate images. For now, binman cannot work inside the
OpenWrt build system because it requires swig, so mark the MT7621
boards as borken to fix the ramips/mt7621 build until someone with
knowledge about Python and swig fixes the underlaying issue.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/uboot-mediatek/Makefile

index a994b8be4dbcecfb0c70de3fdc510410cef7b670..48e6fd5a338ed133b60b2906dff863b9f994d294 100644 (file)
@@ -51,6 +51,7 @@ define U-Boot/mt7621_rfb
   BUILD_TARGET:=ramips
   BUILD_SUBTARGET:=mt7621
   UBOOT_IMAGE:=u-boot-mt7621.bin
+  DEPENDS:=@BROKEN
 endef
 
 define U-Boot/mt7621_nand_rfb
@@ -60,6 +61,7 @@ define U-Boot/mt7621_nand_rfb
   BUILD_TARGET:=ramips
   BUILD_SUBTARGET:=mt7621
   UBOOT_IMAGE:=u-boot-mt7621.bin
+  DEPENDS:=@BROKEN
 endef
 
 define U-Boot/mt7622_rfb1