mediatek: mt7623: include regular AHCI PCI driver
authorDaniel Golle <daniel@makrotopia.org>
Tue, 25 Jan 2022 00:05:43 +0000 (00:05 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 25 Jan 2022 00:38:28 +0000 (00:38 +0000)
The legacy image for the UniElec U7623-02 until now included
kmod-ata-ahci-mtk. The MT7623 chip doesn't have that IP and that
board uses a PCIe-connected AHCI controller for the SATA port and
mSATA-pins of the mPCIe socket. Hence include kmod-ata-ahci instead.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7623.mk

index 89c771e5a06c75fa96d1e7ee32b1b308e4998422..16f59790b042e3e164f3ea9e0cd19f307282b092 100644 (file)
@@ -170,7 +170,7 @@ define Device/unielec_u7623-02-emmc-512m-legacy
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
   DEVICE_PACKAGES := kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc \
-       mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk \
+       mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci \
        partx-utils
   IMAGES := sysupgrade.bin.gz
   IMAGE/sysupgrade.bin.gz := append-kernel |\