mvebu: cortexa72: fix ImageBuilder for IEI Puzzle devices
authorDaniel Golle <daniel@makrotopia.org>
Mon, 4 Jul 2022 17:33:13 +0000 (18:33 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 4 Jul 2022 18:58:13 +0000 (19:58 +0100)
The line trying to generate the standard sdcard.img.gz fails due to
boot.scr not being generated.
Remove the line in order to use the default sdcard.img.gz which is
exactly the same but includes generating the boot.scr file.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 1d3b57dbeeae70ab3a8f71d3bdb6fd41a00e1d22)

target/linux/mvebu/image/cortexa72.mk

index f95ce533ea89978a7db915cb497f15b80532e291..02dccb4d623a9412149a151c4b6204f4807de6f8 100644 (file)
@@ -57,7 +57,6 @@ define Device/iei_puzzle-m901
   DEVICE_VENDOR := iEi
   DEVICE_MODEL := Puzzle-M901
   SOC := cn9131
-  IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
 endef
 TARGET_DEVICES += iei_puzzle-m901
 
@@ -66,6 +65,5 @@ define Device/iei_puzzle-m902
   DEVICE_VENDOR := iEi
   DEVICE_MODEL := Puzzle-M902
   SOC := cn9132
-  IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
 endef
 TARGET_DEVICES += iei_puzzle-m902