mtd: Activate LTO compile option
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Oct 2019 21:32:59 +0000 (22:32 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 29 Nov 2019 23:18:40 +0000 (00:18 +0100)
This decreases the size of the mtd application by 25% on MIPS BE.

old:
20,597 /sbin/mtd

new:
16,421 /sbin/mtd

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 1eb34b7287ed97ad1e2ae60a436babbb5c68076f)

package/system/mtd/Makefile

index c3075554360d70553c5c5a6fb4882ba98f6d5592..17df3bc4750c08dac318d466b4d50cc19e564500 100644 (file)
@@ -36,7 +36,8 @@ endef
 target=$(firstword $(subst -, ,$(BOARD)))
 
 MAKE_FLAGS += TARGET="$(target)"
-TARGET_CFLAGS := $(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall
+TARGET_CFLAGS += -Dtarget_$(target)=1 -Wall -flto
+TARGET_LDFLAGS += -flto=jobserver
 
 ifdef CONFIG_MTD_REDBOOT_PARTS
   MAKE_FLAGS += FIS_SUPPORT=1