ramips: set uImage name of WeVO 11AC NAS and W2914NS v2
authorSungbo Eo <mans0n@gorani.run>
Mon, 7 Oct 2019 12:33:51 +0000 (21:33 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 21 Nov 2019 11:29:37 +0000 (12:29 +0100)
The stock firmware and bootloader only accept uImage with names that
match certain patterns. This patch enables OpenWrt installation from
stock firmware without having to reflash the bootloader or access the
UART console.

Installation via web interface:
1.  Flash **initramfs** image through the stock web interface.
2.  Boot into OpenWrt and perform sysupgrade with sysupgrade image.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
(cherry picked from commit 19800ac095f6ddbba03ccab08e5197b1eec4a49e)
[backported]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/image/mt7621.mk

index aab6097d3369e413b147349dfd79e16044b1dd2e..f13e9c8a4fe40be0e64bf524907ffc73cd2395c3 100644 (file)
@@ -87,6 +87,7 @@ endef
 define Device/11acnas
   DTS := 11ACNAS
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
   DEVICE_TITLE := WeVO 11AC NAS Router
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
@@ -509,6 +510,7 @@ TARGET_DEVICES += vr500
 define Device/w2914nsv2
   DTS := W2914NSV2
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  UIMAGE_NAME := W2914NS-V2(0.0.0)
   DEVICE_TITLE := WeVO W2914NS v2
   DEVICE_PACKAGES := \
        kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic