imagebuilder: allow to specific ROOTFS_PARTSIZE
authorPaul Spooren <mail@aparcar.org>
Sun, 12 Mar 2023 15:56:41 +0000 (16:56 +0100)
committerPaul Spooren <mail@aparcar.org>
Sun, 9 Apr 2023 12:28:16 +0000 (14:28 +0200)
Setting this options modifies the rootfs size of created images. When
installing a large number of packages it may become necessary to
increase the size to have enough storage.

This option is only useful for supported devices, i.e. with an attached
SD Card or installed on a hard drive.

Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 7b7edd25a571568438c886529d3443054e02f55f)

target/imagebuilder/files/Makefile

index aeae98aacdb0094594b874f4e4c021cc09decf72..eadb0ebe8522e4a933db70f57d31d4d2b924871e 100644 (file)
@@ -47,6 +47,7 @@ Building images:
        make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
        make image DISABLED_SERVICES="<svc1> [<svc2> [<svc3> ..]]" # Which services in /etc/init.d/ should be disabled
        make image ADD_LOCAL_KEY=1 # store locally generated signing key in built images
+       make image ROOTFS_PARTSIZE="<size>" # override the default rootfs partition size in MegaBytes
 
 Print manifest:
        List "all" packages which get installed into the image.
@@ -243,7 +244,8 @@ image:
                $(if $(FILES),USER_FILES="$(FILES)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
                $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)") \
-               $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)"))
+               $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)") \
+               $(if $(ROOTFS_PARTSIZE),CONFIG_TARGET_ROOTFS_PARTSIZE="$(ROOTFS_PARTSIZE)"))
 
 manifest: FORCE
        $(MAKE) -s _check_profile