hostapd: mirror ieee80211w ap mode defaults in station mode
authorJo-Philipp Wich <jo@mein.io>
Fri, 20 Sep 2019 11:20:21 +0000 (13:20 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 19:59:58 +0000 (20:59 +0100)
For AP mode, OpenWrt automatically sets ieee80211w to either 1 or 2, depending
on whether the encryption is set to sae-mixed, or sae/owe/eap suite-b.

Mirror the same defaults for client mode connections, in order to allow an
OpenWrt station to associate to an OpenWrt ap with SAE, OWE or Suite-B encryption
without the need to manually specify "option ieee80211w" on the station.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit abb4f4075e791789fdb00731035e08a8cf51555f)

package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index e94d66211d9f59488b6dca205a7adf9ed3310ef8..63e7a5dea14667cc672a1e5238cec9f3692dea12 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 96cfc13a7db0f333fb60cbd01b2ba8b5f810062e..fdbce815dff33b2be27aff29cbf88b052a02b19d 100644 (file)
@@ -754,6 +754,15 @@ wpa_supplicant_add_network() {
                ieee80211w ieee80211r \
                multi_ap
 
+       case "$auth_type" in
+               sae|owe|eap192|eap-eap192)
+                       set_default ieee80211w 2
+               ;;
+               psk-sae)
+                       set_default ieee80211w 1
+               ;;
+       esac
+
        set_default ieee80211r 0
        set_default multi_ap 0