armsr: armv8: enable serial console for Renesas platforms
[openwrt/staging/stintel.git] / include / debug.mk
index faead042dc4a81909cef3689b94f9a11b367ad74..98a1d6e889b820a98fd8d58b3d4a3f42ed6ea999 100644 (file)
@@ -1,9 +1,6 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2007-2020 OpenWrt.org
 
 # debug flags:
 #
@@ -21,6 +18,8 @@ ifeq ($(DUMP),)
   endif
 endif
 
+ifneq ($(DEBUG),)
+
 define debug
 $$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
@@ -38,4 +37,12 @@ $(call warn,$(1),$(2),$(3)   $(4))
 $(4)
 endef
 
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif