at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>
Wed, 14 Aug 2019 00:42:15 +0000 (00:42 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Aug 2019 21:08:44 +0000 (23:08 +0200)
Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
package/boot/at91bootstrap/Makefile
target/linux/at91/image/Makefile

index 82f9ca8e26e3090feff86028483d05ae3252393c..c4edddf848292e2145d03ebbc3df530f5250d9e8 100644 (file)
@@ -128,9 +128,9 @@ AT91BOOTSTRAP_TARGETS := \
     sama5d4_xplainednf_uboot_secure \
     sama5d4_xplaineddf_uboot_secure \
     sama5d4_xplainedsd_uboot_secure \
-       sama5d27_som1_eksd_uboot \
-       sama5d27_som1_ekqspi_uboot \
-       sama5d2_ptc_eknf_uboot \
+    sama5d27_som1_eksd1_uboot \
+    sama5d27_som1_ekqspi_uboot \
+    sama5d2_ptc_eknf_uboot \
     sama5d2_ptc_eksd_uboot
 
 define Build/Compile
index e4c17e3a3c9970af6a4c310505885a93c4d4235b..3a906a6ca8516b2432ad6921292cd5a8e66de3dd 100644 (file)
@@ -55,9 +55,13 @@ define Build/at91-sdcard
     $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
     ::u-boot.bin
 
-  mcopy -i $@.boot \
-    $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
-    ::BOOT.bin
+  $(if $(findstring at91-sama5d27_som1_ek,$@), \
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+          ::BOOT.bin,
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+          ::BOOT.bin)
 
   ./gen_at91_sdcard_img.sh \
       $@.img \