imagebuilder: don't pregenerate package index, strip host binaries
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 12:31:31 +0000 (12:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 12:31:31 +0000 (12:31 +0000)
The package index is generated on first use anyway, therefore it makes no
sense to continue shipping it.

Also sstrip the bundled host binaries when packing the IB to save some
additional space.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44293

target/imagebuilder/Makefile

index ecb8ac7cf4af8756370046afebd21e366c7ce7f2..a8ff4a3c5acaa6642e91d01bdd05686909e9863b 100644 (file)
@@ -56,8 +56,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
          | $(XARGS) rm -rf
        find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
-         | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
-       $(MAKE) -C $(PKG_BUILD_DIR) package_index
+         | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
+       STRIP=sstrip $(SCRIPT_DIR)/rstrip.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
        $(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
 
 download: