iwinfo: don't use the txpower value from debugfs for now, it does not match the value...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 4 Jan 2013 14:08:08 +0000 (14:08 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 4 Jan 2013 14:08:08 +0000 (14:08 +0000)
SVN-Revision: 35007

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index 0bea4ec78f9c9d8dc04e4736e963dd24bdcac5c4..479dcb5f5b6715c0c4d1010ec3bb65af31c012b2 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=37
+PKG_RELEASE:=38
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index ae75e6d86c5ee521da5c7d88f8796c0afe2ddd16..819845ad1d2b05d398b4aafddb051d28c9a09ab6 100644 (file)
@@ -993,6 +993,7 @@ int nl80211_get_channel(const char *ifname, int *buf)
 
 int nl80211_get_txpower(const char *ifname, int *buf)
 {
+#if 0
        char *res;
        char path[PATH_MAX];
 
@@ -1002,6 +1003,7 @@ int nl80211_get_txpower(const char *ifname, int *buf)
 
        if ((*buf = nl80211_readint(path)) > -1)
                return 0;
+#endif
 
        return wext_get_txpower(ifname, buf);
 }