ipq40xx: Fix board-2.bin package name for Plasma Cloud PA1200
authorSven Eckelmann <sven@narfation.org>
Sat, 11 Sep 2021 06:33:30 +0000 (08:33 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 12 Sep 2021 16:52:30 +0000 (18:52 +0200)
The board data file for the Plasma Cloud PA1200 is not part of the default
board-2.bin which is shipped by ath10k-board-qca4019. A typo in the device
package name resulted in a not correctly selected package for the device
specific board-2.bin. The wifi driver has therefore loaded the wrong
calibration information into the wifi chip.

Fixes: ea5bb6bbfee0 ("ipq40xx: add support for Plasma Cloud PA1200")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
target/linux/ipq40xx/image/generic.mk

index 8b504ac84fd27fd8e4711f7933552c4a1d99acb0..da1d1c15d5fbf9bb14236f7ab372f06e1c7f5b35 100644 (file)
@@ -704,7 +704,7 @@ define Device/plasmacloud_pa1200
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-plasmacloud-pa1200
+       DEVICE_PACKAGES := ipq-wifi-plasmacloud_pa1200
 endef
 TARGET_DEVICES += plasmacloud_pa1200