perf: fix building with musl when NLS is enabled
authorMarek Behún <kabel@blackhole.sk>
Sat, 26 Sep 2020 21:42:52 +0000 (21:42 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 14:16:24 +0000 (16:16 +0200)
This package fails with a strange error when building with musl when NLS
is enabled. The configuration thinks that libelf is not present, even
though DEPENDS contains +libelf, because when NLS is enabled, libelf.so
depends on libintl, and the correct LDFLAGS are missing for
libintl-full. This then causes the configuration script to check for
glibc, but this fails because we are using musl.

Signed-off-by: Marek Behún <kabel@blackhole.sk>
package/devel/perf/Makefile

index 3bb403916bfec892ee917719e05c146660f3a26f..e611d5eca3269c33d960c3e36fe281f7eb97cd3e 100644 (file)
@@ -22,6 +22,7 @@ PKG_FLAGS:=nonshared
 PKG_BUILD_DIR:=$(LINUX_DIR)/tools/perf-$(TARGET_DIR_NAME)
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/perf
   SECTION:=devel
@@ -38,6 +39,8 @@ endef
 
 HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
 
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
+
 MAKE_FLAGS = \
        ARCH="$(LINUX_KARCH)" \
        NO_LIBPERL=1 \