bpf: fix broken inclusion of system include
authorChristian Marangi <ansuelsmth@gmail.com>
Fri, 3 May 2024 12:49:58 +0000 (14:49 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 3 May 2024 12:53:11 +0000 (14:53 +0200)
Commit d82c5884c616 ("treewide: make use of new toolchain define")
changed $(TOOLCHAIN_DIR)/include to the new variable
$(TOOLCHAIN_INC_DIRS) that now can contain multiple entry.

Because of this only the first include in $(TOOLCHAIN_INC_DIRS) was
actually included with -isystem, making the other producing warning with
ignored inputs.

Fix this by parsing each entry in $(TOOLCHAIN_INC_DIRS) and adding the
-isystem prefix to correctly include them in the BPF_KERNEL_INCLUDE.

Fixes: d82c5884c616 ("treewide: make use of new toolchain define")
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/bpf.mk

index a3357f0e297f08b88b54c120d7f8298c731ac82c..9abc6601232c0f5f2d49dc1d35dee0d30e777c2f 100644 (file)
@@ -33,7 +33,7 @@ BPF_TARGET:=bpf$(if $(CONFIG_BIG_ENDIAN),eb,el)
 BPF_HEADERS_DIR:=$(STAGING_DIR)/bpf-headers
 
 BPF_KERNEL_INCLUDE := \
-       -nostdinc -isystem $(TOOLCHAIN_INC_DIRS) \
+       -nostdinc $(patsubst %,-isystem %,$(TOOLCHAIN_INC_DIRS)) \
        -I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include \
        -I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include/asm/mach-generic \
        -I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include/generated \