opkg: purge package from cache on hash mismatch
authorPaul Spooren <mail@aparcar.org>
Wed, 25 Nov 2020 08:06:37 +0000 (22:06 -1000)
committerPaul Spooren <mail@aparcar.org>
Wed, 25 Nov 2020 08:06:37 +0000 (22:06 -1000)
61b3c62 opkg_verify_integrity: better logging and error conditions
f73d42f download: purge cached packages that have incorrect checksum
1c1480e download: factor out the logic for building cache filenames
293b1ce libopkg: factor out checksum and size verification
a786e25 download: remove compatibility with old cache naming scheme

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/system/opkg/Makefile

index 79e2932042c063956395e9fd734d257ea972aa17..eb9543c4eaadde381b836307ef03a2dabcbabc58 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.openwrt.org/project/opkg-lede.git
-PKG_SOURCE_DATE:=2020-11-03
-PKG_SOURCE_VERSION:=da9746aaa28fdc63a6e062bf00b25eba52bc8e5f
-PKG_MIRROR_HASH:=9c42a8f7dbce4d50b01c3cd10e1974611ffdd9547c27f8f5725b6237433f54e2
+PKG_SOURCE_DATE:=2020-11-24
+PKG_SOURCE_VERSION:=61b3c62d1c0dbbdcee2d67f56fb112f0af80527a
+PKG_MIRROR_HASH:=4237d525104ba4369a281d71b96307410d592e2aaa6d689306bf7d948def951b
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING