base-files: use $(COMMITCOUNT) in PKG_RELEASE
authorPaul Spooren <mail@aparcar.org>
Sat, 2 Jan 2021 00:18:32 +0000 (14:18 -1000)
committerPaul Spooren <mail@aparcar.org>
Sat, 23 Jan 2021 05:03:53 +0000 (19:03 -1000)
The newly added `$(COMMITCOUNT)` varialbe allows automatic versioning
based on the number of Git commits of a package. Replace *tedious to
bump* and *merge conflict causing* `PKG_RELEASE` and replace it with
`$(COMMITCOUNT)`.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/base-files/Makefile

index f18f221129e4edad4ce390d349fcce40dbd8bf38..d134641cb9d571a613c03c8ec726c0ca1c04488d 100644 (file)
@@ -12,8 +12,8 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=246
 PKG_FLAGS:=nonshared
+PKG_RELEASE:=$(COMMITCOUNT)
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=usign/host ucert/host