ipq40xx: detangle ath10k-board-qca4019 from ath10k-firmware-qca4019*
authorChristian Lamparter <chunkeey@gmail.com>
Fri, 22 Oct 2021 18:38:49 +0000 (20:38 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 30 Oct 2021 14:32:59 +0000 (16:32 +0200)
Back in the day, the board-2.bin came with ath10k-firmware-qca4019.
This changed with
commit c3b2efaf24b5 ("linux-firmware: ath10k: add board firmware packages")
which placed the board-2.bin into a separate package: ath10k-board-qca4019.
This was great, because it addressed one of the caveat of the original
ipq-wifi package:
commit fa03d441e96e ("firmware: add custom IPQ wifi board definitions")

|  2. updating ath10k-firmware-qca4019 will also replace
|      the board-2.bin. For this cases the user needs to
|      manually reinstall the wifi-board package once the
|      ath10k-firmware-qca4019 is updated.

This could be extended further so that ipq-wifi packages
no longer use "install-override" and the various QCA4019
variants list the ath10k-board-qca4019 as a CONFLICT
package.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/firmware/ath10k-ct-firmware/Makefile
package/firmware/linux-firmware/qca_ath10k.mk
target/linux/ipq40xx/Makefile

index 4fd7266f2259686fbad82811ed570fb91e0a6eb7..b210f1a5e442976f45923f6286ed535114440d08 100644 (file)
@@ -292,7 +292,6 @@ $(Package/ath10k-ct-firmware-default)
   CATEGORY:=Firmware
   PROVIDES:=ath10k-firmware-qca4019
   CONFLICTS:=ath10k-firmware-qca4019
-  DEPENDS:=+ath10k-board-qca4019
 endef
 define Package/ath10k-firmware-qca4019-ct-full-htt
 $(Package/ath10k-ct-firmware-default)
@@ -307,7 +306,6 @@ $(Package/ath10k-ct-firmware-default)
     ath10k-firmware-qca4019-ct \
     ath10k-firmware-qca4019-ct-htt
   DEPENDS:=\
-    +ath10k-board-qca4019 \
     +!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
 endef
 define Package/ath10k-firmware-qca4019-ct-htt
@@ -322,7 +320,6 @@ $(Package/ath10k-firmware-default)
     ath10k-firmware-qca4019 \
     ath10k-firmware-qca4019-ct
   DEPENDS:=\
-    +ath10k-board-qca4019 \
     +!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
 endef
 
index d30487441e03db523ece55def36f0d82a6850ae9..d2c709af7ac729a1790de9df340bf584d0455980 100644 (file)
@@ -33,7 +33,7 @@ define Package/ath10k-board-qca4019/install
                $(1)/lib/firmware/ath10k/QCA4019/hw1.0/
 endef
 $(eval $(call BuildPackage,ath10k-board-qca4019))
-Package/ath10k-firmware-qca4019 = $(call Package/firmware-default,ath10k qca4019 firmware,+ath10k-board-qca4019)
+Package/ath10k-firmware-qca4019 = $(call Package/firmware-default,ath10k qca4019 firmware)
 define Package/ath10k-firmware-qca4019/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA4019/hw1.0
        $(INSTALL_DATA) \
index 7b1a0b5b0eebc2ec1838d2c5bf5bc8bdc999e443..3d397cd992b139bc9f024e3e31dec45911093c68 100644 (file)
@@ -19,6 +19,6 @@ DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic-wolfssl \
        kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
-       uboot-envtools
+       ath10k-board-qca4019 uboot-envtools
 
 $(eval $(call BuildTarget))