build: prereq: change minimum make version to 3.82
[openwrt/staging/wigyori.git] / include / prereq-build.mk
index 19904853f1257ec794bd6199987ead6415861a64..801d2e20b70e3d17a79817bc79bb8500503784ed 100644 (file)
@@ -14,8 +14,8 @@ PKG_NAME:=Build dependency
 
 # Required for the toolchain
 $(eval $(call TestHostCommand,working-make, \
-       Please install GNU make v3.81 or later. (This version has bugs), \
-       $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
+       Please install GNU make v3.82 or later. (This version has bugs), \
+       $(MAKE) -v | grep -E 'Make (3\.8[2-9]|3\.9[0-9]|[4-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem, \
@@ -28,15 +28,8 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 4.8 or later, \
-       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       gcc48 --version | grep gcc, \
-       gcc49 --version | grep gcc, \
-       gcc5 --version | grep gcc, \
-       gcc6 --version | grep gcc, \
-       gcc7 --version | grep gcc, \
-       gcc8 --version | grep gcc, \
-       gcc9 --version | grep gcc, \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
@@ -47,15 +40,8 @@ $(eval $(call TestHostCommand,working-gcc, \
 
 $(eval $(call SetupHostCommand,g++, \
        Please install the GNU C++ Compiler (g++) 4.8 or later, \
-       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       g++48 --version | grep g++, \
-       g++49 --version | grep g++, \
-       g++5 --version | grep g++, \
-       g++6 --version | grep g++, \
-       g++7 --version | grep g++, \
-       g++8 --version | grep g++, \
-       g++9 --version | grep g++, \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \