brcm47xx: rename target to bcm47xx
[openwrt/staging/wigyori.git] / package / utils / nvram / Makefile
index 50841f43dab66b46727fbf41b90d170ffd59b3b9..76c254ac77cfe8b32f747815d03e0a241821c6b5 100644 (file)
@@ -8,10 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-PKG_FLAGS:=nonshared
 
 PKG_FLAGS:=nonshared
 
@@ -22,7 +21,7 @@ define Package/nvram
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-  DEPENDS:=@TARGET_brcm47xx||@TARGET_bcm53xx||@TARGET_ar71xx
+  DEPENDS:=@(TARGET_bcm47xx||TARGET_bcm53xx||TARGET_ar71xx||TARGET_ath79)
 endef
 
 define Package/nvram/description
@@ -30,11 +29,6 @@ define Package/nvram/description
  It works on bcm47xx (Linux 2.6) without using the kernel api.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
 define Build/Configure
 endef
 
@@ -46,10 +40,12 @@ define Build/Compile
 endef
 
 define Package/nvram/install
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
+ifneq ($(CONFIG_TARGET_bcm47xx),)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
+endif
 endef
 
 $(eval $(call BuildPackage,nvram))