tools/xz: disable shared library
[openwrt/staging/wigyori.git] / tools / xz / Makefile
index 660f6e899cc38d5d102a057873a8791b4d6fb368..d1f10081aebc55d5a877a3295ec61af0ecd32635 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.0
+PKG_VERSION:=5.2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=0652c09fdbb93ae2ce78c1368ffda612
+PKG_MD5SUM:=d484910b26fec5aff99ee66350589e29
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 
 $(eval $(call HostBuild))