tools/xz: disable shared library
[openwrt/staging/wigyori.git] / tools / xz / Makefile
index 9999006d4884b82b5c644699238d5a33caac1a33..d1f10081aebc55d5a877a3295ec61af0ecd32635 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,21 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.4
+PKG_VERSION:=5.2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://tukaani.org/xz
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=741cd3a5f64b23b7bac56ec5b2258715
+PKG_MD5SUM:=d484910b26fec5aff99ee66350589e29
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
 
 define Host/Install
 
 define Host/Install
-       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
-               AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 
 $(eval $(call HostBuild))
 endef
 
 $(eval $(call HostBuild))