build: move Build/edimax-header to image-commands.mk
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Mon, 1 Aug 2022 04:30:39 +0000 (13:30 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 19 Oct 2022 20:58:12 +0000 (22:58 +0200)
To use from the following devices in ath79 target, move edimax-header to
image-commands.mk.

- ELECOM WRC-300GHBK2-I
- ELECOM WRC-1750GHBK2-I/C

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
include/image-commands.mk
target/linux/ramips/image/Makefile

index 6b4bc4945cbe2a4b846dc5b5503107603c10cd00..492e6933f1928767854c73b661ee9b8613fa7452 100644 (file)
@@ -218,6 +218,11 @@ define Build/copy-file
        cat "$(1)" > "$@"
 endef
 
+define Build/edimax-header
+       $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
+       @mv $@.new $@
+endef
+
 define Build/elecom-product-header
        $(eval product=$(word 1,$(1)))
        $(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))
index d48b22023115ea79f4f9e9d788389aa0204b1095..0992d6ba9ff7a078c49e51b8373c2ba738475732 100644 (file)
@@ -28,11 +28,6 @@ LOADER_FLASH_START := $(ldrflashstart-y)
 
 KERNEL_DTB = kernel-bin | append-dtb | lzma
 
-define Build/edimax-header
-       $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
-       @mv $@.new $@
-endef
-
 define Build/jcg-header
        $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
                $(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \