kernel: add references to openwrt alternative button handling
authorJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 07:07:28 +0000 (07:07 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 07:07:28 +0000 (07:07 +0000)
Add documentation that makes it easier to find the alternative,
recommended, and default handling for buttons in OpenWrt.

Signed-off-by: Karl Palsson <karlp@tweak.net.au>
SVN-Revision: 43989

package/kernel/linux/modules/input.mk

index 32adc1ecf49b34df42bf28b465924b575282e3d9..f42cbaec06b519ea725e19296c2471e35db99d55 100644 (file)
@@ -82,6 +82,9 @@ endef
 define KernelPackage/input-gpio-keys/description
  This driver implements support for buttons connected
  to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys))
@@ -101,6 +104,9 @@ endef
 
 define KernelPackage/input-gpio-keys-polled/description
  Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys-polled))