Initial support for Telsey CPVA642 boards (no vlans, no DSL, GPIO led/buttons not...
authorDaniel Dickinson <crazycshore@gmail.com>
Fri, 19 Nov 2010 13:41:54 +0000 (13:41 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Fri, 19 Nov 2010 13:41:54 +0000 (13:41 +0000)
SVN-Revision: 24040

target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch [new file with mode: 0644]

index 56d048bbbd07fb0e7b8011ef895d88a70a4ff4a7..4f41889a52ffe19cb46b349f67c9fbe3083aef8f 100644 (file)
@@ -172,6 +172,9 @@ define Image/Build
        # RG100A,DB120 etc.
        $(call Image/Build/RG100A,$(1),96358VW2,6358,0x20000,RG100A_DB120)
 
+       # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
+       $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
+
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch b/target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch
new file mode 100644 (file)
index 0000000..bc71425
--- /dev/null
@@ -0,0 +1,37 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -677,6 +677,26 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_CPVA642 = {
++      .name                           = "CPVA642",
++      .expected_cpu_id                = 0x6358,
++
++      .has_uart0                      = 1,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++
++      .enet1 = {
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .has_ohci0 = 1,
++      .has_ehci0 = 1,
++
++      /* GPIOs not yet known for this device */
++};
++
++
+ static struct board_info __initdata board_AGPFS0 = {
+       .name                           = "AGPF-S0",
+       .expected_cpu_id                = 0x6358,
+@@ -1339,6 +1359,7 @@ static const struct board_info __initdat
+       &board_96358vw,
+       &board_96358vw2,
+       &board_AGPFS0,
++      &board_CPVA642,
+       &board_DWVS0,
+       &board_nb4_ser_r0,
+       &board_nb4_ser_r1,