kmod-via-velocity depends on kmod-crc-ccitt (#8730)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 29 Jan 2011 22:06:23 +0000 (22:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 29 Jan 2011 22:06:23 +0000 (22:06 +0000)
SVN-Revision: 25244

package/kernel/modules/netdevices.mk

index 1290b7f5fa9f37fd477863aa491b717606d8f5e9..7b544c8e462b9d060fe2892007af8d5b835f4f8f 100644 (file)
@@ -158,7 +158,7 @@ $(eval $(call KernelPackage,via-rhine))
 define KernelPackage/via-velocity
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=VIA Velocity Gigabit Ethernet Adapter kernel support
-  DEPENDS:=@TARGET_ixp4xx||TARGET_mpc83xx||TARGET_x86
+  DEPENDS:=@TARGET_ixp4xx||TARGET_mpc83xx||TARGET_x86 +kmod-crc-ccitt
   KCONFIG:=CONFIG_VIA_VELOCITY
   FILES:=$(LINUX_DIR)/drivers/net/via-velocity.ko
   AUTOLOAD:=$(call AutoLoad,50,via-velocity)